Beware the Fruit-Eating Lion

If you are about to switch to OS 7 Lion, you probably are aware that the old PowerPC applications will no longer run. One of the most important is Quicken 2007 or earlier. There has been lots of discussion about this on the web, and a quick Google search will bring up...